Back to build
Raw log | Switch to full mode | Login

Test 'WebRtcGetUserMediaBrowserTest.GetUserMediaAfterStopElementCapture/1' completed with the following status(es): 'FAILURE','SUCCESS' Test 'WebRtcGetUserMediaBrowserTest.GetUserMediaAfterStopElementCapture/1' had the following logs when run: ================================================================================ [ RUN ] WebRtcGetUserMediaBrowserTest.GetUserMediaAfterStopElementCapture/1 Xlib: extension "RANDR" missing on display ":105". DevTools listening on ws://127.0.0.1:46406/devtools/browser/6a971bbd-8c6f-447d-9a1d-a785cd55973a [21973:21973:0522/005900.863922:ERROR:validation_errors.cc(76)] Invalid message: VALIDATION_ERROR_UNEXPECTED_NULL_POINTER (null field 1) [21973:21994:0522/005900.864033:ERROR:render_process_host_impl.cc(4646)] Terminating render process for bad Mojo message: Received bad user message: Validation failed for ImageCapture RequestValidator [VALIDATION_ERROR_UNEXPECTED_NULL_POINTER (null field 1) [21973:21994:0522/005900.864079:ERROR:bad_message.cc(27)] Terminating renderer for bad IPC message, reason 123 [21973:21973:0522/005900.870403:INFO:browser_test_utils.cc(2228)] DOMMessageQueue::RenderProcessGone 2 ../../content/browser/webrtc/webrtc_content_browsertest_base.cc:75: Failure Value of: ExecuteScriptAndExtractString(shell(), javascript, &result) Actual: false Expected: true Failed to execute javascript getUserMediaAfterStopCanvasCapture(). Stack trace: #0 0x55f0b66d499f StackTraceGetter::CurrentStackTrace() #1 0x55f0b66ddf0c testing::internal::UnitTestImpl::CurrentOsStackTraceExceptTop() #2 0x55f0b66dd869 testing::internal::AssertHelper::operator=() #3 0x55f0b5df3eb1 content::WebRtcContentBrowserTestBase::ExecuteJavascriptAndReturnResult() #4 0x55f0b5df40a0 content::WebRtcContentBrowserTestBase::ExecuteJavascriptAndWaitForOk() #5 0x55f0b5e014a1 content::WebRtcGetUserMediaBrowserTest_GetUserMediaAfterStopElementCapture_Test::RunTestOnMainThread() #6 0x55f0b7b295a1 content::BrowserTestBase::ProxyRunTestOnMainThreadLoop() #7 0x55f0b7b8ae05 content::ShellBrowserMainParts::PreMainMessageLoopRun() #8 0x55f0b752066f content::BrowserMainLoop::PreMainMessageLoopRun() #9 0x55f0b78efd77 content::StartupTaskRunner::RunAllTasksNow() #10 0x55f0b751f258 content::BrowserMainLoop::CreateStartupTasks() #11 0x55f0b75224f2 content::BrowserMainRunnerImpl::Initialize() #12 0x55f0b751d6ff content::BrowserMain() #13 0x55f0b742f9e9 content::ContentMainRunnerImpl::RunServiceManager() #14 0x55f0b742f676 content::ContentMainRunnerImpl::Run() #15 0x55f0b929c60b service_manager::Main() #16 0x55f0b68345d1 content::ContentMain() From javascript: (nothing) When executing 'getUserMediaAfterStopCanvasCapture()' ../../content/browser/webrtc/webrtc_content_browsertest_base.cc:100: Failure Failed Stack trace: #0 0x55f0b66d499f StackTraceGetter::CurrentStackTrace() #1 0x55f0b66ddf0c testing::internal::UnitTestImpl::CurrentOsStackTraceExceptTop() #2 0x55f0b66dd869 testing::internal::AssertHelper::operator=() #3 0x55f0b5df4159 content::WebRtcContentBrowserTestBase::ExecuteJavascriptAndWaitForOk() #4 0x55f0b5e014a1 content::WebRtcGetUserMediaBrowserTest_GetUserMediaAfterStopElementCapture_Test::RunTestOnMainThread() #5 0x55f0b7b295a1 content::BrowserTestBase::ProxyRunTestOnMainThreadLoop() #6 0x55f0b7b8ae05 content::ShellBrowserMainParts::PreMainMessageLoopRun() #7 0x55f0b752066f content::BrowserMainLoop::PreMainMessageLoopRun() #8 0x55f0b78efd77 content::StartupTaskRunner::RunAllTasksNow() #9 0x55f0b751f258 content::BrowserMainLoop::CreateStartupTasks() #10 0x55f0b75224f2 content::BrowserMainRunnerImpl::Initialize() #11 0x55f0b751d6ff content::BrowserMain() #12 0x55f0b742f9e9 content::ContentMainRunnerImpl::RunServiceManager() #13 0x55f0b742f676 content::ContentMainRunnerImpl::Run() #14 0x55f0b929c60b service_manager::Main() #15 0x55f0b68345d1 content::ContentMain() [21973:21994:0522/005901.113044:ERROR:browser_process_sub_thread.cc(221)] Waited 5 ms for network service [ FAILED ] WebRtcGetUserMediaBrowserTest.GetUserMediaAfterStopElementCapture/1, where GetParam() = true (533 ms) [ RUN ] WebRtcGetUserMediaBrowserTest.GetUserMediaAfterStopElementCapture/1 Xlib: extension "RANDR" missing on display ":105". DevTools listening on ws://127.0.0.1:42392/devtools/browser/f828819f-3a8d-4b24-ab4b-ca0f81476584 [29416:29416:0522/005922.010561:INFO:CONSOLE(16)] "Test Success", source: http://127.0.0.1:39327/media/webrtc_test_utilities.js (16) [29416:29425:0522/005922.199459:ERROR:browser_process_sub_thread.cc(221)] Waited 5 ms for network service [ OK ] WebRtcGetUserMediaBrowserTest.GetUserMediaAfterStopElementCapture/1 (417 ms) ================================================================================