Back to build
Raw log | Switch to full mode | Login

npm install in dir /b/s/w/ir/kitchen-workdir/infra/go/src/infra/appengine/sheriff-o-matic/frontend: allow_subannotations: False base_name: 'sheriff-o-matic npm install' cmd: ['npm', 'install'] cwd: '/b/s/w/ir/kitchen-workdir/infra/go/src/infra/appengine/sheriff-o-matic/frontend' env: {'PATH': '/b/s/w/ir/kitchen-workdir/packages/bin:%(PATH)s'} env_prefixes: {} env_suffixes: {} infra_step: False name: 'sheriff-o-matic npm install' nest_level: 0 ok_ret: frozenset([0]) trigger_specs: () full environment: BOTO_CONFIG: /b/s/w/ir/tmp/gsutil_task/.boto BUILDBUCKET_EXPERIMENTAL: FALSE CIPD_CACHE_DIR: /b/s/cipd_cache/cache CIPD_PROTOCOL: v2 DEVSHELL_CLIENT_PORT: 37706 DOCKER_CONFIG: /b/s/w/ir/tmp/docker_cfg_task DOCKER_TMPDIR: /b/s/w/ir/tmp/docker_tmp_task GIT_CONFIG_NOSYSTEM: 1 GIT_TERMINAL_PROMPT: 0 HOME: /home/chrome-bot INFRA_GIT_WRAPPER_HOME: /b/s/w/ir/tmp/git_home_task LOGDOG_COORDINATOR_HOST: logs.chromium.org LOGDOG_STREAM_PREFIX: buildbucket/cr-buildbucket.appspot.com/8921412701342734576 LOGDOG_STREAM_PROJECT: infra LOGDOG_STREAM_SERVER_PATH: unix:/b/s/w/ir/tmp/ld.sock LOGNAME: chrome-bot LUCI_CONTEXT: /b/s/w/itQOgv63/luci_context.413655192 MAC_CHROMIUM_TMPDIR: /b/s/w/ir/tmp/t MAIL: /var/mail/chrome-bot NO_GCE_CHECK: False PATH: /b/s/w/ir/kitchen-workdir/packages/bin:/b/s/w/ir/cipd_bin_packages:/b/s/w/ir/cipd_bin_packages/bin:/b/s/cipd_cache/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin PWD: /b/s/w/ir PYTHONIOENCODING: UTF-8 PYTHONUNBUFFERED: 1 SHELL: /bin/bash SHLVL: 1 SUDO_COMMAND: /usr/bin/python /b/s/swarming_bot.zip start_bot SUDO_GID: 0 SUDO_UID: 0 SUDO_USER: root SWARMING_BOT_ID: gce-trusty-e833d7b0-us-west1-b-dmgc SWARMING_EXTERNAL_BOT_SETUP: 1 SWARMING_HEADLESS: 1 SWARMING_SERVER: https://chromium-swarm.appspot.com SWARMING_TASK_ID: 430c66a9a3a4ef11 TEMP: /b/s/w/ir/tmp/t TEMPDIR: /b/s/w/ir/tmp/t TERM: linux TMP: /b/s/w/ir/tmp/t TMPDIR: /b/s/w/ir/tmp/t USER: chrome-bot USERNAME: chrome-bot VPYTHON_VIRTUALENV_ROOT: /b/s/w/ir/cache/vpython _: /b/s/w/ir/cipd_bin_packages/vpython npm WARN notice [SECURITY] adm-zip has the following vulnerability: 1 high. Go here for more details: https://nodesecurity.io/advisories?search=adm-zip&version=0.4.7 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] lodash has the following vulnerability: 1 moderate. Go here for more details: https://nodesecurity.io/advisories?search=lodash&version=4.17.5 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] minimatch has the following vulnerability: 1 high. Go here for more details: https://nodesecurity.io/advisories?search=minimatch&version=1.0.0 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] lodash has the following vulnerability: 1 low. Go here for more details: https://nodesecurity.io/advisories?search=lodash&version=2.4.2 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] lodash has the following vulnerability: 1 low. Go here for more details: https://nodesecurity.io/advisories?search=lodash&version=4.16.2 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] tunnel-agent has the following vulnerability: 1 moderate. Go here for more details: https://nodesecurity.io/advisories?search=tunnel-agent&version=0.4.3 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] sshpk has the following vulnerability: 1 high. Go here for more details: https://nodesecurity.io/advisories?search=sshpk&version=1.13.1 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] stringstream has the following vulnerability: 1 moderate. Go here for more details: https://nodesecurity.io/advisories?search=stringstream&version=0.0.5 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] debug has the following vulnerability: 1 low. Go here for more details: https://nodesecurity.io/advisories?search=debug&version=2.3.3 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] debug has the following vulnerability: 1 low. Go here for more details: https://nodesecurity.io/advisories?search=debug&version=2.2.0 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] debug has the following vulnerability: 1 low. Go here for more details: https://nodesecurity.io/advisories?search=debug&version=2.3.3 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] debug has the following vulnerability: 1 low. Go here for more details: https://nodesecurity.io/advisories?search=debug&version=2.3.3 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] ms has the following vulnerability: 1 moderate. Go here for more details: https://nodesecurity.io/advisories?search=ms&version=0.7.0 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] mime has the following vulnerability: 1 moderate. Go here for more details: https://nodesecurity.io/advisories?search=mime&version=1.2.11 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] debug has the following vulnerability: 1 low. Go here for more details: https://nodesecurity.io/advisories?search=debug&version=2.1.3 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] fresh has the following vulnerability: 1 high. Go here for more details: https://nodesecurity.io/advisories?search=fresh&version=0.2.4 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] parsejson has the following vulnerability: 1 high. Go here for more details: https://nodesecurity.io/advisories?search=parsejson&version=0.0.3 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] https-proxy-agent has the following vulnerability: 1 high. Go here for more details: https://nodesecurity.io/advisories?search=https-proxy-agent&version=1.0.0 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] lodash has the following vulnerability: 1 low. Go here for more details: https://nodesecurity.io/advisories?search=lodash&version=3.6.0 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] hoek has the following vulnerability: 1 moderate. Go here for more details: https://nodesecurity.io/advisories?search=hoek&version=2.16.3 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] minimatch has the following vulnerability: 1 high. Go here for more details: https://nodesecurity.io/advisories?search=minimatch&version=2.0.10 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. npm WARN notice [SECURITY] minimatch has the following vulnerability: 1 high. Go here for more details: https://nodesecurity.io/advisories?search=minimatch&version=2.0.10 - Run `npm i npm@latest -g` to upgrade your npm version, and then `npm audit` to get more info. > puppeteer@1.11.0 install /b/s/w/ir/kitchen-workdir/infra/go/src/infra/appengine/sheriff-o-matic/frontend/node_modules/puppeteer > node install.js Chromium downloaded to /b/s/w/ir/kitchen-workdir/infra/go/src/infra/appengine/sheriff-o-matic/frontend/node_modules/puppeteer/.local-chromium/linux-609904 > wd@1.5.0 install /b/s/w/ir/kitchen-workdir/infra/go/src/infra/appengine/sheriff-o-matic/frontend/node_modules/wd > node scripts/build-browser-scripts > sauce-connect-launcher@1.2.3 postinstall /b/s/w/ir/kitchen-workdir/infra/go/src/infra/appengine/sheriff-o-matic/frontend/node_modules/sauce-connect-launcher > node scripts/install.js || nodejs scripts/install.js > wct-sauce@1.8.6 postinstall /b/s/w/ir/kitchen-workdir/infra/go/src/infra/appengine/sheriff-o-matic/frontend/node_modules/wct-sauce > node scripts/postinstall.js Prefetching the Sauce Connect binary. Missing Sauce Connect local proxy, downloading dependency This will only happen once. Downloading 8.94MB Archive checksum verified. Unzipping /b/s/w/ir/kitchen-workdir/infra/go/src/infra/appengine/sheriff-o-matic/frontend/node_modules/sauce-connect-launcher/sc/sc-4.5.3-linux.tar.gz Removing /b/s/w/ir/kitchen-workdir/infra/go/src/infra/appengine/sheriff-o-matic/frontend/node_modules/sauce-connect-launcher/sc/sc-4.5.3-linux.tar.gz Sauce Connect downloaded correctly > wct-local@2.1.0 postinstall /b/s/w/ir/kitchen-workdir/infra/go/src/infra/appengine/sheriff-o-matic/frontend/node_modules/wct-local > node scripts/postinstall.js ---------- selenium-standalone installation starting ---------- --- selenium install: from: https://selenium-release.storage.googleapis.com/3.7/selenium-server-standalone-3.7.1.jar to: /b/s/w/ir/kitchen-workdir/infra/go/src/infra/appengine/sheriff-o-matic/frontend/node_modules/selenium-standalone/.selenium/selenium-server/3.7.1-server.jar --- chrome install: from: https://chromedriver.storage.googleapis.com/2.33/chromedriver_linux64.zip to: /b/s/w/ir/kitchen-workdir/infra/go/src/infra/appengine/sheriff-o-matic/frontend/node_modules/selenium-standalone/.selenium/chromedriver/2.33-x64-chromedriver --- firefox install: from: https://github.com/mozilla/geckodriver/releases/download/v0.19.1/geckodriver-v0.19.1-linux64.tar.gz to: /b/s/w/ir/kitchen-workdir/infra/go/src/infra/appengine/sheriff-o-matic/frontend/node_modules/selenium-standalone/.selenium/geckodriver/0.19.1-x64-geckodriver ----- selenium-standalone installation finished ----- npm WARN som@1.0.0 No repository field. added 684 packages in 22.672s