Back to build
Raw log | Switch to full mode | Login

{ "shards": [ { "bot_dimensions": [ { "key": "caches", "value": [ "builder_36c85ebda7bed74f4f047df6d39aba7f824e167a4ee669897e735d76b78f3755_v2", "builder_b0f70dc86e1d0a6e3ffcc95c8ea25406997bbb2d50b410328d5542c81c91a3c4_v2", "builder_bb916aa04528ee67d2b1a92762359cb8ccddee7b959f80ef03c82cd1d43de7e9_v2", "builder_be27d8b138dfc387884512fad7facac1b0f67a4766cc008796394f7e6facbc61_v2", "builder_cdfb7e4c0be45bc1d321702c4190674b9bda32c6c4e50f46ac29be7962cacf17_v2", "builder_e13f4302820d9262fb21c7c0dbc470fc3f63b30e43224495de56520c8aea703c_v2", "git", "goma_v2", "swarming_module_cache_vpython", "vpython" ] }, { "key": "cores", "value": [ "8" ] }, { "key": "cpu", "value": [ "x86", "x86-64", "x86-64-Broadwell_GCE", "x86-64-avx2" ] }, { "key": "gce", "value": [ "1" ] }, { "key": "gpu", "value": [ "none" ] }, { "key": "id", "value": [ "luci-dart-try-xenial-73-nzk1" ] }, { "key": "image", "value": [ "chrome-xenial-19041001-3b730ae8765" ] }, { "key": "inside_docker", "value": [ "0" ] }, { "key": "kvm", "value": [ "0" ] }, { "key": "locale", "value": [ "en_US.UTF-8" ] }, { "key": "machine_type", "value": [ "n1-standard-8" ] }, { "key": "os", "value": [ "Linux", "Ubuntu", "Ubuntu-16.04" ] }, { "key": "pool", "value": [ "dart.tests", "luci.dart.try" ] }, { "key": "python", "value": [ "2.7.12" ] }, { "key": "server_version", "value": [ "4267-53b17d5" ] }, { "key": "zone", "value": [ "us", "us-central", "us-central1", "us-central1-b" ] } ], "bot_id": "luci-dart-try-xenial-73-nzk1", "bot_version": "bd68e04e43fc4d1b7b5b65890a29c5d5bae55ab1423851733f92abd7e13dda14", "cipd_pins": { "client_package": { "package_name": "infra/tools/cipd/linux-amd64", "version": "nFftZl2kFquaI2EUmPGwzbc5sIbCocl9L55UeASqlLsC" }, "packages": [ { "package_name": "infra/python/cpython/linux-amd64", "path": ".swarming_module", "version": "46c0c897ca0f053799ee41fd148bb7a47232df47" }, { "package_name": "infra/tools/luci/logdog/butler/linux-amd64", "path": ".swarming_module", "version": "2737ea8ed9b958f4d5aa9ffe106115a649ada241" }, { "package_name": "infra/tools/luci/vpython-native/linux-amd64", "path": ".swarming_module", "version": "tfTmX4aGCfFtfQucj_nEfwiNisK0RmpKrITkZMBBq3cC" }, { "package_name": "infra/tools/luci/vpython/linux-amd64", "path": ".swarming_module", "version": "bmnYyAg9mbM_538s1dIP1hZZmOtc8C7ssF41ztN2cr0C" }, { "package_name": "dart/dart-sdk/linux-amd64", "path": "tools/sdks", "version": "_NNVITsg60i2IEbTCMkOw6aWDgGP1Assud9v72MOAOMC" } ] }, "completed_ts": "2019-04-18T19:25:18.924516", "costs_usd": [ 0.09273095819378531 ], "created_ts": "2019-04-18T19:02:06.885160", "duration": 779.8105471134186, "modified_ts": "2019-04-18T19:25:18.924516", "name": "vm tests_shard_4/Linux/bfec50e658/vm-kernel-precomp-obfuscate-linux-release-x64/3478", "output": "/b/s/swarming_bot.1.zip/third_party/requests/__init__.py:83: RequestsDependencyWarning: Old version of cryptography ([1, 2, 3]) may cause slowdown.\ntools/testing/dart/main.dart:1: Warning: Interpreting this as package URI, 'package:test_dart/main.dart'.\nTest configurations:\n dartkp-obfuscate-linux-release-x64(architecture: x64, compiler: dartkp, mode: release, runtime: dart_precompiled, system: linux, builder-tag: obfuscated, vm-options: [--obfuscate], dart2js-options: [], timeout: null, preview-dart-2)\nSuites tested: samples, standalone, standalone_2, corelib_2, language_2, vm, benchmark_smoke, utils, lib_2, analyze_library, service, kernel, ffi\n dartkp-obfuscate-linux-release-x64(architecture: x64, compiler: dartkp, mode: release, runtime: dart_precompiled, system: linux, builder-tag: obfuscated, vm-options: [--obfuscate], dart2js-options: [], timeout: null, preview-dart-2)\nSuites tested: observatory_ui\nTotal: 1180 tests\n * 166 tests will be skipped (112 skipped by design)\n * 8 tests are expected to be flaky but not crash\n * 5 tests are expected to flaky crash\n * 962 tests are expected to pass\n * 1 tests are expected to fail that we won't fix\n * 35 tests are expected to fail that we should fix\n * 1 tests are expected to crash that we should fix\n * 0 tests are allowed to timeout\n * 2 could not be categorized or are in multiple categories\n\n298 out of 1014 completed\nTests running for 5 minutes\n\nFAILED: dartkp-dart_precompiled release_x64 language_2/set_literals/invalid_set_literal_test/08\nExpected: MissingCompileTimeError\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm_compile_to_kernel []\" (took 634ms):\nDART_CONFIGURATION=ReleaseX64 /b/s/w/ir/pkg/vm/tool/gen_kernel --aot --platform=out/ReleaseX64/vm_platform_strong.dill -o /b/s/w/ir/out/ReleaseX64/generated_compilations/dartkp/multitest_language_2_set_literals_invalid_set_literal_test_08/out.dill /b/s/w/ir/out/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_08.dart --packages=/b/s/w/ir/.packages -Ddart.developer.causal_async_stacks=true\n\nexit code:\n1\n\nstdout:\nout/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_08.dart:12:8: Error: The key 'Duration {dart.core::_duration: 0}' does not have a primitive operator '=='.\n - 'Duration' is from 'dart:core'.\n var o //\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartkp-obfuscate-linux-release-x64 language_2/set_literals/invalid_set_literal_test/08\n\n\nFAILED: dartkp-dart_precompiled release_x64 language_2/set_literals/invalid_set_literal_test/09\nExpected: MissingCompileTimeError\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm_compile_to_kernel []\" (took 581ms):\nDART_CONFIGURATION=ReleaseX64 /b/s/w/ir/pkg/vm/tool/gen_kernel --aot --platform=out/ReleaseX64/vm_platform_strong.dill -o /b/s/w/ir/out/ReleaseX64/generated_compilations/dartkp/multitest_language_2_set_literals_invalid_set_literal_test_09/out.dill /b/s/w/ir/out/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_09.dart --packages=/b/s/w/ir/.packages -Ddart.developer.causal_async_stacks=true\n\nexit code:\n1\n\nstdout:\nout/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_09.dart:12:8: Error: The key '4.2' does not have a primitive operator '=='.\n var o //\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartkp-obfuscate-linux-release-x64 language_2/set_literals/invalid_set_literal_test/09\n\n\nFAILED: dartkp-dart_precompiled release_x64 language_2/set_literals/invalid_set_literal_test/10\nExpected: MissingCompileTimeError\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm_compile_to_kernel []\" (took 527ms):\nDART_CONFIGURATION=ReleaseX64 /b/s/w/ir/pkg/vm/tool/gen_kernel --aot --platform=out/ReleaseX64/vm_platform_strong.dill -o /b/s/w/ir/out/ReleaseX64/generated_compilations/dartkp/multitest_language_2_set_literals_invalid_set_literal_test_10/out.dill /b/s/w/ir/out/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_10.dart --packages=/b/s/w/ir/.packages -Ddart.developer.causal_async_stacks=true\n\nexit code:\n1\n\nstdout:\nout/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_10.dart:12:8: Error: The key '3.5' does not have a primitive operator '=='.\n var o //\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartkp-obfuscate-linux-release-x64 language_2/set_literals/invalid_set_literal_test/10\n\n805 out of 1014 completed\nTests running for 10 minutes\n\n=== Failure summary:\n\n\nFAILED: dartkp-dart_precompiled release_x64 language_2/set_literals/invalid_set_literal_test/08\nExpected: MissingCompileTimeError\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm_compile_to_kernel []\" (took 634ms):\nDART_CONFIGURATION=ReleaseX64 /b/s/w/ir/pkg/vm/tool/gen_kernel --aot --platform=out/ReleaseX64/vm_platform_strong.dill -o /b/s/w/ir/out/ReleaseX64/generated_compilations/dartkp/multitest_language_2_set_literals_invalid_set_literal_test_08/out.dill /b/s/w/ir/out/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_08.dart --packages=/b/s/w/ir/.packages -Ddart.developer.causal_async_stacks=true\n\nexit code:\n1\n\nstdout:\nout/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_08.dart:12:8: Error: The key 'Duration {dart.core::_duration: 0}' does not have a primitive operator '=='.\n - 'Duration' is from 'dart:core'.\n var o //\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartkp-obfuscate-linux-release-x64 language_2/set_literals/invalid_set_literal_test/08\n\n\nFAILED: dartkp-dart_precompiled release_x64 language_2/set_literals/invalid_set_literal_test/09\nExpected: MissingCompileTimeError\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm_compile_to_kernel []\" (took 581ms):\nDART_CONFIGURATION=ReleaseX64 /b/s/w/ir/pkg/vm/tool/gen_kernel --aot --platform=out/ReleaseX64/vm_platform_strong.dill -o /b/s/w/ir/out/ReleaseX64/generated_compilations/dartkp/multitest_language_2_set_literals_invalid_set_literal_test_09/out.dill /b/s/w/ir/out/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_09.dart --packages=/b/s/w/ir/.packages -Ddart.developer.causal_async_stacks=true\n\nexit code:\n1\n\nstdout:\nout/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_09.dart:12:8: Error: The key '4.2' does not have a primitive operator '=='.\n var o //\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartkp-obfuscate-linux-release-x64 language_2/set_literals/invalid_set_literal_test/09\n\n\nFAILED: dartkp-dart_precompiled release_x64 language_2/set_literals/invalid_set_literal_test/10\nExpected: MissingCompileTimeError\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm_compile_to_kernel []\" (took 527ms):\nDART_CONFIGURATION=ReleaseX64 /b/s/w/ir/pkg/vm/tool/gen_kernel --aot --platform=out/ReleaseX64/vm_platform_strong.dill -o /b/s/w/ir/out/ReleaseX64/generated_compilations/dartkp/multitest_language_2_set_literals_invalid_set_literal_test_10/out.dill /b/s/w/ir/out/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_10.dart --packages=/b/s/w/ir/.packages -Ddart.developer.causal_async_stacks=true\n\nexit code:\n1\n\nstdout:\nout/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_10.dart:12:8: Error: The key '3.5' does not have a primitive operator '=='.\n var o //\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartkp-obfuscate-linux-release-x64 language_2/set_literals/invalid_set_literal_test/10\n\n\n\n===\n=== 3 tests failed\n===\n\n\n--- Total time: 12:56 ---\n0:00:16.805876 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/set_intersection_test\n0:00:16.258428 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/iterable_single_test\n0:00:16.177309 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/expression_test\n0:00:15.944229 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/format_exception_test\n0:00:15.757299 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/bool_from_environment_test\n0:00:15.536762 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/list_to_string2_test\n0:00:15.507712 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/stacktrace_fromstring_test\n0:00:10.086959 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/string_static_test\n0:00:06.664731 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/iterable_skip_test\n0:00:06.215783 - precompiler - dartkp-dart_precompiled release_x64/language_2/classes_static_method_clash_test\n0:00:06.016592 - precompiler - dartkp-dart_precompiled release_x64/language_2/nested_comments_test\n0:00:05.999109 - precompiler - dartkp-dart_precompiled release_x64/language_2/closure_type_arguments_test\n0:00:05.993421 - precompiler - dartkp-dart_precompiled release_x64/language_2/nosuchmethod_forwarding/nosuchmethod_forwarding_arguments_test\n0:00:05.901794 - assemble - dartkp-dart_precompiled release_x64/corelib_2/stacktrace_fromstring_test\n0:00:05.893905 - precompiler - dartkp-dart_precompiled release_x64/lib_2/math/min_max_test\n0:00:05.868528 - precompiler - dartkp-dart_precompiled release_x64/language_2/await_started_immediately_test\n0:00:05.834512 - precompiler - dartkp-dart_precompiled release_x64/language_2/regress_28278_test/0\n0:00:05.764719 - precompiler - dartkp-dart_precompiled release_x64/language_2/async_star_test/01\n0:00:05.748573 - precompiler - dartkp-dart_precompiled release_x64/language_2/async_star_test/02\n0:00:05.740940 - assemble - dartkp-dart_precompiled release_x64/corelib_2/bool_from_environment_test\nINFO: Core dump archiving is activated\nINFO: No unexpected crashes recorded\n", "outputs_ref": { "isolated": "7766bcc8ba10fb09673cc8a0c622f03f4cb46854", "isolatedserver": "https://isolateserver.appspot.com", "namespace": "default-gzip" }, "run_id": "444aa55b35100311", "server_versions": [ "4267-53b17d5" ], "started_ts": "2019-04-18T19:11:48.601322", "state": "COMPLETED", "tags": [ "build_is_experimental:false", "buildername:vm-kernel-precomp-obfuscate-linux-release-x64", "buildnumber:3478", "cpu:x86-64", "data:bfec50e65866b29228a534df83d1951670fbd79f", "master:client.dart", "name:vm", "os:Linux", "pool:dart.tests", "priority:25", "service_account:none", "slavename:luci-dart-try-xenial-16-jz74", "spec_name:dart.ci.sandbox:vm-kernel-precomp-obfuscate-linux-release-x64", "stepname:vm tests_shard_4", "swarming.pool.template:none", "swarming.pool.version:d517960f98d7ac3674286a858291d7ef64cc7416", "user:None" ], "task_id": "444aa55b35100310", "try_number": "1" } ] }