Back to build
Raw log | Switch to full mode | Login

{ "shards": [ { "bot_dimensions": [ { "key": "caches", "value": [ "builder_2563ba1605eb6aedbf6c78e079a052c63ef6125ebd9603d3bc10df777632bdda_v2", "builder_2a98a8b518ca4a18ae82ffedef2eea93c4a884abc1d231637aa846a898cf2599_v2", "builder_36c85ebda7bed74f4f047df6d39aba7f824e167a4ee669897e735d76b78f3755_v2", "builder_6c7694be62530312549608e9d9f54f1be67378e128f8af72bc6de1353d411aac_v2", "builder_820fa8e7d7ff17b94bd2f041ec0b46ce0171183f181a810f5631c5d703141cd3_v2", "builder_b24b9e9c7bdcc8c15b82ff72de3c9e4817df38aeec4906b757083d6c2a012484_v2", "builder_c762dd9ce592b3c0de5905eac1695e5c33a5cbbb648bd52fabdb48f7948d9041_v2", "builder_cdfb7e4c0be45bc1d321702c4190674b9bda32c6c4e50f46ac29be7962cacf17_v2", "builder_d12c26ea02592d766fa897b3a9f1968750a07bd9a90f9cf17f0bdf313cb29dcb_v2", "builder_d21bd4d2a5e8d960c49288e2ecfe80623305e9909fef5813928fd002a7f11d64_v2", "builder_d755b13ea27529b8d954505a3de473d31600dc8feb775fe9c37f67f09f316caa_v2", "builder_f9219a911dfbeb4ff836ddef0b336af22f54bd9ecdbeeae68c2671e10bb80306_v2", "git", "goma_v2", "swarming_module_cache_vpython", "vpython" ] }, { "key": "cores", "value": [ "8" ] }, { "key": "cpu", "value": [ "x86", "x86-64", "x86-64-Broadwell_GCE", "x86-64-avx2" ] }, { "key": "gce", "value": [ "1" ] }, { "key": "gpu", "value": [ "none" ] }, { "key": "id", "value": [ "luci-dart-try-xenial-87-7aqx" ] }, { "key": "image", "value": [ "chrome-xenial-19041001-3b730ae8765" ] }, { "key": "inside_docker", "value": [ "0" ] }, { "key": "kvm", "value": [ "0" ] }, { "key": "locale", "value": [ "en_US.UTF-8" ] }, { "key": "machine_type", "value": [ "n1-standard-8" ] }, { "key": "os", "value": [ "Linux", "Ubuntu", "Ubuntu-16.04" ] }, { "key": "pool", "value": [ "dart.tests", "luci.dart.try" ] }, { "key": "python", "value": [ "2.7.12" ] }, { "key": "server_version", "value": [ "4274-a0a5f8c" ] }, { "key": "zone", "value": [ "us", "us-central", "us-central1", "us-central1-b" ] } ], "bot_id": "luci-dart-try-xenial-87-7aqx", "bot_version": "ed4565f416d57730e75be543776f9c0eb206896ef8831a69fda252ac9fa2095a", "cipd_pins": { "client_package": { "package_name": "infra/tools/cipd/linux-amd64", "version": "nFftZl2kFquaI2EUmPGwzbc5sIbCocl9L55UeASqlLsC" }, "packages": [ { "package_name": "infra/python/cpython/linux-amd64", "path": ".swarming_module", "version": "46c0c897ca0f053799ee41fd148bb7a47232df47" }, { "package_name": "infra/tools/luci/logdog/butler/linux-amd64", "path": ".swarming_module", "version": "2737ea8ed9b958f4d5aa9ffe106115a649ada241" }, { "package_name": "infra/tools/luci/vpython-native/linux-amd64", "path": ".swarming_module", "version": "tfTmX4aGCfFtfQucj_nEfwiNisK0RmpKrITkZMBBq3cC" }, { "package_name": "infra/tools/luci/vpython/linux-amd64", "path": ".swarming_module", "version": "bmnYyAg9mbM_538s1dIP1hZZmOtc8C7ssF41ztN2cr0C" }, { "package_name": "dart/dart-sdk/linux-amd64", "path": "tools/sdks", "version": "_NNVITsg60i2IEbTCMkOw6aWDgGP1Assud9v72MOAOMC" } ] }, "completed_ts": "2019-04-25T20:38:35.721689", "costs_usd": [ 0.08850410448254854 ], "created_ts": "2019-04-25T20:23:05.528486", "duration": 749.0918040275574, "modified_ts": "2019-04-25T20:38:35.721689", "name": "vm tests_shard_4/Linux/4947a1824e/vm-kernel-precomp-obfuscate-linux-release-x64/3562", "output": "/b/s/swarming_bot.1.zip/third_party/requests/__init__.py:83: RequestsDependencyWarning: Old version of cryptography ([1, 2, 3]) may cause slowdown.\ntools/testing/dart/main.dart:1: Warning: Interpreting this as package URI, 'package:test_dart/main.dart'.\nTest configurations:\n dartkp-obfuscate-linux-release-x64(architecture: x64, compiler: dartkp, mode: release, runtime: dart_precompiled, system: linux, builder-tag: obfuscated, vm-options: [--obfuscate], dart2js-options: [], timeout: null, preview-dart-2)\nSuites tested: samples, standalone, standalone_2, corelib_2, language_2, vm, benchmark_smoke, utils, lib_2, analyze_library, service, kernel, ffi\n dartkp-obfuscate-linux-release-x64(architecture: x64, compiler: dartkp, mode: release, runtime: dart_precompiled, system: linux, builder-tag: obfuscated, vm-options: [--obfuscate], dart2js-options: [], timeout: null, preview-dart-2)\nSuites tested: observatory_ui\nTotal: 1180 tests\n * 166 tests will be skipped (112 skipped by design)\n * 8 tests are expected to be flaky but not crash\n * 5 tests are expected to flaky crash\n * 962 tests are expected to pass\n * 1 tests are expected to fail that we won't fix\n * 35 tests are expected to fail that we should fix\n * 1 tests are expected to crash that we should fix\n * 0 tests are allowed to timeout\n * 2 could not be categorized or are in multiple categories\n\n308 out of 1014 completed\nTests running for 5 minutes\n\nFAILED: dartkp-dart_precompiled release_x64 language_2/set_literals/invalid_set_literal_test/09\nExpected: MissingCompileTimeError\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm_compile_to_kernel []\" (took 518ms):\nDART_CONFIGURATION=ReleaseX64 /b/s/w/ir/pkg/vm/tool/gen_kernel --aot --platform=out/ReleaseX64/vm_platform_strong.dill -o /b/s/w/ir/out/ReleaseX64/generated_compilations/dartkp/multitest_language_2_set_literals_invalid_set_literal_test_09/out.dill /b/s/w/ir/out/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_09.dart --packages=/b/s/w/ir/.packages -Ddart.developer.causal_async_stacks=true\n\nexit code:\n1\n\nstdout:\nout/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_09.dart:12:8: Error: The key '4.2' does not have a primitive operator '=='.\n var o //\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartkp-obfuscate-linux-release-x64 language_2/set_literals/invalid_set_literal_test/09\n\n\nFAILED: dartkp-dart_precompiled release_x64 language_2/set_literals/invalid_set_literal_test/08\nExpected: MissingCompileTimeError\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm_compile_to_kernel []\" (took 606ms):\nDART_CONFIGURATION=ReleaseX64 /b/s/w/ir/pkg/vm/tool/gen_kernel --aot --platform=out/ReleaseX64/vm_platform_strong.dill -o /b/s/w/ir/out/ReleaseX64/generated_compilations/dartkp/multitest_language_2_set_literals_invalid_set_literal_test_08/out.dill /b/s/w/ir/out/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_08.dart --packages=/b/s/w/ir/.packages -Ddart.developer.causal_async_stacks=true\n\nexit code:\n1\n\nstdout:\nout/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_08.dart:12:8: Error: The key 'Duration {dart.core::_duration: 0}' does not have a primitive operator '=='.\n - 'Duration' is from 'dart:core'.\n var o //\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartkp-obfuscate-linux-release-x64 language_2/set_literals/invalid_set_literal_test/08\n\n\nFAILED: dartkp-dart_precompiled release_x64 language_2/set_literals/invalid_set_literal_test/10\nExpected: MissingCompileTimeError\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm_compile_to_kernel []\" (took 555ms):\nDART_CONFIGURATION=ReleaseX64 /b/s/w/ir/pkg/vm/tool/gen_kernel --aot --platform=out/ReleaseX64/vm_platform_strong.dill -o /b/s/w/ir/out/ReleaseX64/generated_compilations/dartkp/multitest_language_2_set_literals_invalid_set_literal_test_10/out.dill /b/s/w/ir/out/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_10.dart --packages=/b/s/w/ir/.packages -Ddart.developer.causal_async_stacks=true\n\nexit code:\n1\n\nstdout:\nout/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_10.dart:12:8: Error: The key '3.5' does not have a primitive operator '=='.\n var o //\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartkp-obfuscate-linux-release-x64 language_2/set_literals/invalid_set_literal_test/10\n\n833 out of 1014 completed\nTests running for 10 minutes\n\n=== Failure summary:\n\n\nFAILED: dartkp-dart_precompiled release_x64 language_2/set_literals/invalid_set_literal_test/09\nExpected: MissingCompileTimeError\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm_compile_to_kernel []\" (took 518ms):\nDART_CONFIGURATION=ReleaseX64 /b/s/w/ir/pkg/vm/tool/gen_kernel --aot --platform=out/ReleaseX64/vm_platform_strong.dill -o /b/s/w/ir/out/ReleaseX64/generated_compilations/dartkp/multitest_language_2_set_literals_invalid_set_literal_test_09/out.dill /b/s/w/ir/out/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_09.dart --packages=/b/s/w/ir/.packages -Ddart.developer.causal_async_stacks=true\n\nexit code:\n1\n\nstdout:\nout/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_09.dart:12:8: Error: The key '4.2' does not have a primitive operator '=='.\n var o //\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartkp-obfuscate-linux-release-x64 language_2/set_literals/invalid_set_literal_test/09\n\n\nFAILED: dartkp-dart_precompiled release_x64 language_2/set_literals/invalid_set_literal_test/08\nExpected: MissingCompileTimeError\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm_compile_to_kernel []\" (took 606ms):\nDART_CONFIGURATION=ReleaseX64 /b/s/w/ir/pkg/vm/tool/gen_kernel --aot --platform=out/ReleaseX64/vm_platform_strong.dill -o /b/s/w/ir/out/ReleaseX64/generated_compilations/dartkp/multitest_language_2_set_literals_invalid_set_literal_test_08/out.dill /b/s/w/ir/out/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_08.dart --packages=/b/s/w/ir/.packages -Ddart.developer.causal_async_stacks=true\n\nexit code:\n1\n\nstdout:\nout/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_08.dart:12:8: Error: The key 'Duration {dart.core::_duration: 0}' does not have a primitive operator '=='.\n - 'Duration' is from 'dart:core'.\n var o //\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartkp-obfuscate-linux-release-x64 language_2/set_literals/invalid_set_literal_test/08\n\n\nFAILED: dartkp-dart_precompiled release_x64 language_2/set_literals/invalid_set_literal_test/10\nExpected: MissingCompileTimeError\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm_compile_to_kernel []\" (took 555ms):\nDART_CONFIGURATION=ReleaseX64 /b/s/w/ir/pkg/vm/tool/gen_kernel --aot --platform=out/ReleaseX64/vm_platform_strong.dill -o /b/s/w/ir/out/ReleaseX64/generated_compilations/dartkp/multitest_language_2_set_literals_invalid_set_literal_test_10/out.dill /b/s/w/ir/out/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_10.dart --packages=/b/s/w/ir/.packages -Ddart.developer.causal_async_stacks=true\n\nexit code:\n1\n\nstdout:\nout/ReleaseX64/generated_tests/language_2/set_literals/invalid_set_literal_test_10.dart:12:8: Error: The key '3.5' does not have a primitive operator '=='.\n var o //\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartkp-obfuscate-linux-release-x64 language_2/set_literals/invalid_set_literal_test/10\n\n\n\n===\n=== 3 tests failed\n===\n\n\n--- Total time: 12:26 ---\n0:00:16.195228 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/iterable_single_test\n0:00:16.103501 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/expression_test\n0:00:15.958040 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/list_to_string2_test\n0:00:15.858650 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/format_exception_test\n0:00:15.839496 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/set_intersection_test\n0:00:15.613973 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/stacktrace_fromstring_test\n0:00:15.521677 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/bool_from_environment_test\n0:00:10.093388 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/string_static_test\n0:00:06.947539 - vm_compile_to_kernel [] - dartkp-dart_precompiled release_x64/corelib_2/iterable_skip_test\n0:00:06.295482 - precompiler - dartkp-dart_precompiled release_x64/language_2/classes_static_method_clash_test\n0:00:05.706973 - precompiler - dartkp-dart_precompiled release_x64/language_2/async_star_test/none\n0:00:05.622689 - precompiler - dartkp-dart_precompiled release_x64/language_2/async_star_test/04\n0:00:05.618464 - precompiler - dartkp-dart_precompiled release_x64/corelib_2/bigint_test/12/2\n0:00:05.565364 - precompiler - dartkp-dart_precompiled release_x64/language_2/async_star_test/02\n0:00:05.560770 - precompiler - dartkp-dart_precompiled release_x64/corelib_2/bigint_test/13/1\n0:00:05.554697 - precompiler - dartkp-dart_precompiled release_x64/language_2/async_star_test/01\n0:00:05.508376 - precompiler - dartkp-dart_precompiled release_x64/corelib_2/bigint_test/05/2\n0:00:05.501684 - precompiler - dartkp-dart_precompiled release_x64/lib_2/math/min_max_test\n0:00:05.429850 - precompiler - dartkp-dart_precompiled release_x64/corelib_2/bigint_test/02/2\n0:00:05.382257 - precompiler - dartkp-dart_precompiled release_x64/corelib_2/bigint_test/04/1\nINFO: Core dump archiving is activated\nINFO: No unexpected crashes recorded\n", "outputs_ref": { "isolated": "9f4a76c28f0abe40460e0b9363bf5450f2862447", "isolatedserver": "https://isolateserver.appspot.com", "namespace": "default-gzip" }, "run_id": "446efc0256dee111", "server_versions": [ "4274-a0a5f8c" ], "started_ts": "2019-04-25T20:25:38.792830", "state": "COMPLETED", "tags": [ "build_is_experimental:false", "buildername:vm-kernel-precomp-obfuscate-linux-release-x64", "buildnumber:3562", "cpu:x86-64", "data:4947a1824eabf1beb68b18091301075f3c6c21b6", "master:client.dart", "name:vm", "os:Linux", "pool:dart.tests", "priority:25", "service_account:none", "slavename:luci-dart-try-xenial-93-19br", "spec_name:dart.ci.sandbox:vm-kernel-precomp-obfuscate-linux-release-x64", "stepname:vm tests_shard_4", "swarming.pool.template:none", "swarming.pool.version:82448814faa4820fccac763aebde958e33abecf8", "user:None" ], "task_id": "446efc0256dee110", "try_number": "1" } ] }