Back to build
Raw log | Switch to full mode | Login

{ "shards": [ { "bot_dimensions": [ { "key": "caches", "value": [ "swarming_module_cache_vpython" ] }, { "key": "cores", "value": [ "8" ] }, { "key": "cpu", "value": [ "x86", "x86-64", "x86-64-Broadwell_GCE", "x86-64-avx2" ] }, { "key": "gce", "value": [ "1" ] }, { "key": "gpu", "value": [ "none" ] }, { "key": "id", "value": [ "dart-tests-xenial-44-fp6l" ] }, { "key": "image", "value": [ "chrome-xenial-19052201-9cb74617499" ] }, { "key": "inside_docker", "value": [ "0" ] }, { "key": "kvm", "value": [ "1" ] }, { "key": "locale", "value": [ "en_US.UTF-8" ] }, { "key": "machine_type", "value": [ "n1-standard-8" ] }, { "key": "os", "value": [ "Linux", "Ubuntu", "Ubuntu-16.04" ] }, { "key": "pool", "value": [ "dart.tests" ] }, { "key": "python", "value": [ "2.7.12" ] }, { "key": "server_version", "value": [ "4303-bae210e" ] }, { "key": "zone", "value": [ "us", "us-central", "us-central1", "us-central1-b" ] } ], "bot_id": "dart-tests-xenial-44-fp6l", "bot_version": "ec327ca04645110c43b092f9eb2d259c2461902ca791b7bcf390931d49bda575", "cipd_pins": { "client_package": { "package_name": "infra/tools/cipd/linux-amd64", "version": "nFftZl2kFquaI2EUmPGwzbc5sIbCocl9L55UeASqlLsC" }, "packages": [ { "package_name": "infra/python/cpython/linux-amd64", "path": ".swarming_module", "version": "46c0c897ca0f053799ee41fd148bb7a47232df47" }, { "package_name": "infra/tools/luci/logdog/butler/linux-amd64", "path": ".swarming_module", "version": "2737ea8ed9b958f4d5aa9ffe106115a649ada241" }, { "package_name": "infra/tools/luci/vpython-native/linux-amd64", "path": ".swarming_module", "version": "tfTmX4aGCfFtfQucj_nEfwiNisK0RmpKrITkZMBBq3cC" }, { "package_name": "infra/tools/luci/vpython/linux-amd64", "path": ".swarming_module", "version": "bmnYyAg9mbM_538s1dIP1hZZmOtc8C7ssF41ztN2cr0C" }, { "package_name": "dart/third_party/co19", "path": "tests/co19_2/src", "version": "lEvldXE7_8AmaQallfGUHkEh8MlY92shpcHyI8REB1UC" }, { "package_name": "dart/dart-sdk/linux-amd64", "path": "tools/sdks", "version": "ONcFzOT_pfqGEGugNzfiFhsNIbazF1HGRU-DeF0jBBwC" } ] }, "completed_ts": "2019-05-24T21:42:53.390329", "costs_usd": [ 0.025721233089063798 ], "created_ts": "2019-05-24T21:39:08.334521", "duration": 192.4775629043579, "modified_ts": "2019-05-24T21:42:53.390329", "name": "vm co19 tests_shard_3/Linux/3089a3ff68/vm-kernel-linux-release-x64/5548", "output": "/b/s/swarming_bot.2.zip/third_party/requests/__init__.py:83: RequestsDependencyWarning: Old version of cryptography ([1, 2, 3]) may cause slowdown.\ntools/testing/dart/main.dart:1: Warning: Interpreting this as package URI, 'package:test_dart/main.dart'.\nTest configuration:\n dartk-linux-release-x64(architecture: x64, compiler: dartk, mode: release, runtime: vm, system: linux, vm-options: [], dart2js-options: [], timeout: null, preview-dart-2)\nSuites tested: co19_2\nTotal: 2429 tests\n * 371 tests will be skipped (339 skipped by design)\n * 2 tests are expected to be flaky but not crash\n * 2 tests are expected to flaky crash\n * 1976 tests are expected to pass\n * 0 tests are expected to fail that we won't fix\n * 62 tests are expected to fail that we should fix\n * 14 tests are expected to crash that we should fix\n * 0 tests are allowed to timeout\n * 2 could not be categorized or are in multiple categories\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/none\nExpected: Crash\nActual: CompileTimeError\n\n--- Command \"vm\" (took 668ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_none.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_none.dart:30:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/none\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/01\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 670ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_01.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_01.dart:30:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/01\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/03\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 621ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_03.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_03.dart:30:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/03\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/02\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 771ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_02.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_02.dart:30:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/02\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/04\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 723ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_04.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_04.dart:30:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/04\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/05\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 674ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_05.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_05.dart:30:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/05\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/01\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 655ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_01.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_01.dart:28:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/01\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/none\nExpected: Crash\nActual: CompileTimeError\n\n--- Command \"vm\" (took 725ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_none.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_none.dart:28:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/none\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/02\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 778ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_02.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_02.dart:28:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/02\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/04\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 631ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_04.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_04.dart:28:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/04\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/03\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 703ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_03.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_03.dart:28:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/03\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/05\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 697ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_05.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_05.dart:28:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/05\n\n\n=== Failure summary:\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/none\nExpected: Crash\nActual: CompileTimeError\n\n--- Command \"vm\" (took 668ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_none.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_none.dart:30:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/none\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/01\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 670ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_01.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_01.dart:30:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/01\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/03\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 621ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_03.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_03.dart:30:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/03\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/02\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 771ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_02.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_02.dart:30:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/02\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/04\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 723ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_04.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_04.dart:30:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/04\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/05\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 674ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_05.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12_05.dart:30:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t12/05\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/01\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 655ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_01.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_01.dart:28:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/01\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/none\nExpected: Crash\nActual: CompileTimeError\n\n--- Command \"vm\" (took 725ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_none.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_none.dart:28:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/none\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/02\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 778ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_02.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_02.dart:28:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/02\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/04\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 631ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_04.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_04.dart:28:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/04\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/03\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 703ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_03.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_03.dart:28:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/03\n\n\nFAILED: dartk-vm release_x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/05\nExpected: Crash\nActual: Pass\nMissing expected compile error.\n\n--- Command \"vm\" (took 697ms):\nDART_CONFIGURATION=ReleaseX64 out/ReleaseX64/dart --suppress-core-dump --enable-experiment=constant-update-2018,triple-shift --ignore-unrecognized-flags --packages=/b/s/w/ir/.packages /b/s/w/ir/out/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_05.dart\n\nexit code:\n254\n\nstderr:\nout/ReleaseX64/generated_tests/co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08_05.dart:28:37: Error: Expected an identifier, but got '>'.\n const MyClass(i1, i2) : a = (i1 >>> i2);\n ^\n\n--- Re-run this test:\npython tools/test.py -n dartk-linux-release-x64 co19_2/LanguageFeatures/Constant-update-2018/NewOperators_A01_t08/05\n\n\n\n===\n=== 12 tests failed\n===\n\n\n--- Total time: 03:10 ---\n0:00:45.792509 - vm - dartk-vm release_x64/co19_2/LibTest/io/Link/watch_A01_t01\n0:00:06.949553 - vm - dartk-vm release_x64/co19_2/LibTest/isolate/Isolate/spawnUri_A05_t04\n0:00:06.769054 - vm - dartk-vm release_x64/co19_2/LibTest/io/RandomAccessFile/unlock_A01_t02\n0:00:05.623385 - vm - dartk-vm release_x64/co19_2/LibTest/collection/ListBase/ListBase_class_A01_t01\n0:00:05.040005 - vm - dartk-vm release_x64/co19_2/LibTest/isolate/Isolate/spawnUri_A05_t02\n0:00:03.080811 - vm - dartk-vm release_x64/co19_2/LibTest/async/StreamController/stream_A02_t01\n0:00:02.967323 - vm - dartk-vm release_x64/co19_2/LibTest/async/Stream/Stream.fromFutures_A04_t01\n0:00:02.874782 - vm - dartk-vm release_x64/co19_2/LibTest/io/HttpServer/sessionTimeout_A01_t02\n0:00:02.549465 - vm - dartk-vm release_x64/co19_2/LibTest/collection/ListMixin/ListMixin_class_A01_t03\n0:00:02.106068 - vm - dartk-vm release_x64/co19_2/LibTest/io/Stdin/first_A04_t01\n0:00:02.008954 - vm - dartk-vm release_x64/co19_2/LibTest/io/HttpClientRequest/maxRedirects_A03_t01\n0:00:01.847805 - vm - dartk-vm release_x64/co19_2/LibTest/io/HttpClientRequest/followRedirects_A04_t01\n0:00:01.736341 - vm - dartk-vm release_x64/co19_2/LibTest/isolate/Isolate/removeErrorListener_A02_t01\n0:00:01.717452 - vm - dartk-vm release_x64/co19_2/LibTest/io/ProcessSignal/watch_A01_t02\n0:00:01.674735 - vm - dartk-vm release_x64/co19_2/LibTest/async/StreamController/StreamController.broadcast_A09_t02\n0:00:01.632424 - vm - dartk-vm release_x64/co19_2/LibTest/async/Stream/Stream.periodic_A04_t02\n0:00:01.566657 - vm - dartk-vm release_x64/co19_2/LibTest/io/RandomAccessFile/lockSync_A04_t01\n0:00:01.536263 - vm - dartk-vm release_x64/co19_2/LibTest/io/RandomAccessFile/lockSync_A04_t03\n0:00:01.533671 - vm - dartk-vm release_x64/co19_2/LibTest/io/RandomAccessFile/lockSync_A03_t01\n0:00:01.463994 - vm - dartk-vm release_x64/co19_2/LibTest/io/RandomAccessFile/lock_A03_t01\nINFO: Core dump archiving is activated\nINFO: No unexpected crashes recorded\n", "outputs_ref": { "isolated": "e9c4227291e63e83a3a1b639a372e9dd05633d23", "isolatedserver": "https://isolateserver.appspot.com", "namespace": "default-gzip" }, "run_id": "45049a0e88e31b11", "server_versions": [ "4303-bae210e" ], "started_ts": "2019-05-24T21:39:09.906810", "state": "COMPLETED", "tags": [ "build_is_experimental:false", "buildername:vm-kernel-linux-release-x64", "buildnumber:5548", "cpu:x86-64", "data:3089a3ff680be7529e8211d4067d5578b84047d4", "name:vm", "os:Linux", "pool:dart.tests", "priority:25", "service_account:none", "slavename:luci-dart-try-xenial-24-jc2r", "spec_name:dart.ci.sandbox:vm-kernel-linux-release-x64", "stepname:vm co19 tests_shard_3", "swarming.pool.template:none", "swarming.pool.version:8261c400e0abfdf3d7aebb1e1a358f7c7e6c6a0b", "user:None" ], "task_id": "45049a0e88e31b10", "try_number": "1" } ] }